Third party supplier issue causing booking failures across different travel types

Incident Report for Click Travel Ltd

Resolved

This incident has been resolved. Apologies for any inconvenience caused.
Posted Sep 11, 2025 - 14:02 BST

Monitoring

Our supplier has applied a fix for the issue and things seem back to normal. We will continue to monitor.
Posted Sep 11, 2025 - 13:12 BST

Investigating

A third party supplier issue is causing booking failures across different travel types. If you are impacted by the issue, please try again later. We apologise for any inconvenience caused.
Posted Sep 11, 2025 - 13:04 BST
This incident affected: Booking / Checkout.