Emails and faxes not being sent
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Jan 23, 2020 - 17:59 GMT
Monitoring
A fix has been implemented and emails and faxes are now being sent - we apologise for the inconvenience caused. We are still monitoring the situation.
Posted Jan 23, 2020 - 13:49 GMT
Investigating
We have identified an issue where all emails and faxes coming from travel.cloud (including welcome emails and booking confirmations) are not being sent.

We’re currently working to resolve this issue and apologise for the inconvenience caused.
Posted Jan 23, 2020 - 12:58 GMT
This incident affected: Communications (Email (Outbound & Inbound), Faxes).