Delays in response time for customer support
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 16:43 BST
Update
We are continuing to work on a fix for this issue.
Posted Sep 24, 2021 - 16:43 BST
Identified
Due to unprecedented volumes created by our suppliers, we are experiencing very high volumes in our contact center. We are working hard to clear our backlog, in the meantime, we are focused on inquiries nearest to the date of travel, please bear with us if you are waiting on email communications from us for travel, not in the next 48 hours.
Posted Sep 23, 2021 - 16:52 BST
This incident affected: Communications (Email (Outbound & Inbound), Online Live Chat).