Travelodge hotel bookings unavailable
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved. Apologies for any inconvenience.
Posted Jun 13, 2023 - 10:15 BST
Monitoring
Our payment provider has implemented a fix which we are monitoring. Travelodge hotels are now available on the platform again.
Posted Jun 13, 2023 - 07:39 BST
Investigating
Due to an issue with our third party payment supplier, Travelodge hotels are currently unavailable on the platform. We are working with our supplier to understand the issue.
Posted Jun 12, 2023 - 16:26 BST
This incident affected: Search (Hotel Search) and Booking / Checkout.