Travelodge Hotel Search Outage

Incident Report for Click Travel Ltd

Resolved

The issue has been resolved.
Posted May 29, 2025 - 14:43 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2025 - 12:45 BST

Investigating

We have identified an issue with Travelodge hotel search and we are currently investigating with our suppliers.
Posted May 29, 2025 - 12:00 BST
This incident affected: Search (Hotel Search).