Premier Inn bookings intermittently failing

Incident Report for Click Travel Ltd

Resolved

Premier Inn bookings remain stable. Apologies for any inconvenience caused.
Posted Feb 27, 2025 - 14:57 GMT

Monitoring

Our supplier has fixed their issue and Premier Inn bookings are stable again. We will continue to monitor.
Posted Feb 27, 2025 - 12:23 GMT

Identified

Due to a problem with our third party provider, bookings with Premier Inn are intermittently failing. If you experience a failure, please try again and if the problem persists, contact support. Apologies for any inconvenience caused.
Posted Feb 27, 2025 - 11:28 GMT
This incident affected: Booking / Checkout.