Reduced availability of British Airways fares

Incident Report for Click Travel Ltd

Resolved

We are seeing good performance from our supplier so are closing this incident. Apologies for any inconvenience caused.
Posted Mar 21, 2025 - 15:39 GMT

Update

Whilst the majority of issues have now subsided a few issues remain. We are working with our supplier to understand the them. We apologise for any inconvenience caused.
Posted Mar 20, 2025 - 16:17 GMT

Investigating

Due to an unplanned outage with a third party supplier we are seeing reduced availability of some British Airways fares. We are working with our supplier to understand the issue. If the fare you require isn't available, please try again and if the issue persists please contact customer support. We apologise for any inconvenience caused.
Posted Mar 20, 2025 - 13:01 GMT
This incident affected: Booking / Checkout and Search (Flight Search).