Premier Inn booking failures

Incident Report for Click Travel Ltd

Resolved

This incident has been resolved. Apologies for any inconvenience caused.
Posted Jul 31, 2025 - 14:18 BST

Monitoring

Our supplier has informed us that they have resolved the issue. We are monitoring status of the fix.
Posted Jul 31, 2025 - 14:07 BST

Investigating

Our third party supplier is experiencing a problem which is resulting in Premier Inn bookings failing. If you are impacted by the problem, please try your booking again later. We apologise for any inconvenience caused.
Posted Jul 31, 2025 - 13:10 BST
This incident affected: Booking / Checkout.