Major Outage detected with phone system provider
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Jan 19, 2021 - 21:06 GMT
Monitoring
Telephone Connection to our agents has now been restored. We will continue to monitor the performance over the next few hours
Posted Jan 19, 2021 - 14:47 GMT
Identified
A problem has been identified with our phone system provider that is preventing calls reaching us, we have identified the problem and are working to restore connectivity.
Posted Jan 19, 2021 - 14:03 GMT
This incident affected: Communications (Telephone).