Travelodge hotels not available
Incident Report for Click Travel Ltd
Resolved
Our supplier has resolved the issue and Travelodges are available on the platform again. Apologies for any inconvenience caused.
Posted Aug 31, 2023 - 11:55 BST
Investigating
Due to an issue with one of our suppliers, Travelodge hotels are currently not available on the platform. We are working with our supplier to understand the issue. If you urgently need to book a Travelodge, please contact customer support. Apologies for any inconvenience caused.
Posted Aug 31, 2023 - 09:36 BST
This incident affected: Search (Hotel Search).