Booking.com Outage

Incident Report for Click Travel Ltd

Resolved

This incident has been resolved. Apologies for any inconvenience caused.
Posted Aug 12, 2025 - 14:12 BST

Monitoring

We have been advised by our supplier that this issue has resolved and we have started seeing successful bookings going through. We are continuing to monitor.
Posted Aug 12, 2025 - 13:04 BST

Identified

We have identified an issue with Booking.com and are currently speaking with them to resolve.
Posted Aug 12, 2025 - 11:43 BST
This incident affected: Search (Hotel Search).