Issues with exchanging Train bookings on routes impacted by the weekends incident

Incident Report for Click Travel Ltd

Resolved

This incident has been resolved. There were issues in the supply chain caused by cancelled services due to the incident.
Posted Jun 30, 2026 - 09:13 BST

Update

We are continuing to investigate the issue and are currently waiting for an update from our supplier.
Posted Jun 24, 2026 - 09:08 BST

Investigating

We have identified an issue exchanging bookings that are on route(s) affected by the incident on the weekend. We are working with our supplier to resolve this
Posted Jun 23, 2026 - 09:48 BST
This incident affected: Booking / Checkout.