Service Disruption with travel.cloud bookings
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 18, 2019 - 14:42 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Mar 18, 2019 - 14:20 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Mar 18, 2019 - 14:13 GMT
Update
Investigation is still ongoing to understand the cause of the issues we're experiencing and how to resolve - we thank you again for your patience.
Posted 3 months ago. Mar 18, 2019 - 13:18 GMT
Update
We are continuing to investigate the issue - apologies again for the inconvenience.
Posted 3 months ago. Mar 18, 2019 - 12:51 GMT
Investigating
We are currently experiencing a service disruption with travel.cloud bookings

Our engineering team is working to identify the root cause and implement a solution. Most users may be affected.

We will update you as soon as possible.
Posted 3 months ago. Mar 18, 2019 - 12:34 GMT
This incident affected: Booking / Checkout.