Premier Inn hotels currently unavailable
Incident Report for Click Travel Ltd
Resolved
The incident has been resolved. Apologies for any inconvenience caused.
Posted Jan 18, 2024 - 13:58 GMT
Monitoring
Our third party provider have resolved their issue and we are seeing Premier Inns on the platform again. We will continue to monitor.
Posted Jan 18, 2024 - 11:41 GMT
Investigating
Due to an issue with our third party provider, Premier Inn hotels are currently unavailable on the platform. If you need to urgently book a Premier Inn, please contact customer support. Apologies for any inconvenience caused.
Posted Jan 18, 2024 - 10:15 GMT
This incident affected: Search (Hotel Search).