Some train tickets are incorrectly flagged as out of policy
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 12, 2019 - 13:05 BST
Investigating
Some train tickets are incorrectly flagged as out of policy, we're investigating and will keep you updated.
Posted 2 months ago. Apr 12, 2019 - 11:51 BST
This incident affected: Booking / Checkout.