Ryanair bookings slow to confirm.
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 17:11 BST
Investigating
We've identified an issue with Ryanair bookings being slow to confirm. This is due to an issue with our supplier. We have contacted our supplier and they are currently investigating.
Posted Aug 31, 2023 - 15:41 BST
This incident affected: Booking / Checkout.