Reduced availability of some Aurigny, Blue Islands & Loganair airline fares

Incident Report for Click Travel Ltd

Resolved

Our third party supplier has resolved their issue and things are looking back to normal. Apologies for any inconvenience caused.
Posted Apr 15, 2025 - 14:44 BST

Update

Our third party supplier has resolved their issue and things are looking back to normal. Apologies for any inconvenience caused.
Posted Apr 15, 2025 - 14:05 BST

Investigating

Due to intermittency via a third party supplier we are seeing reduced availability of some Aurigny, Blue Islands & Loganair airline fares. The system issues are also affecting changes to existing bookings and online check in actions. Please allow for extra time at the airport whilst ground staff revert to manual procedures. We apologise for any inconvenience caused. We are working with our supplier to understand the issue.
Posted Apr 08, 2025 - 11:16 BST
This incident affected: Search (Flight Search).