Service Disruption displaying Flight packages
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 11:37 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 01, 2020 - 10:29 BST
Investigating
We are currently experiencing a service disruption displaying Flight packages

Our engineering team is working to identify the root cause and implement a solution. Flight packages may not be displayed normally, which will prevent you from continuing any further.

This is only impacting flights that have a touchdown en route, e.g. a London to Sydney flight that touches down in Singapore en route before continuing the journey. If you are searching for a flight that include one or more non-stop flights, you will not experience an issue.

We will update you as soon as possible.
Posted Apr 01, 2020 - 09:55 BST
This incident affected: Booking / Checkout and Search (Flight Search).