Users unable to access platform
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Jan 15, 2020 - 14:37 GMT
Monitoring
A fix has been implemented and users should now be able to access the platform. We are still monitoring the situation.
Posted Jan 15, 2020 - 12:08 GMT
Investigating
We are aware of an issue with users being unable to access the platform and are currently investigating.
Posted Jan 15, 2020 - 12:04 GMT
This incident affected: User Accounts.