Travelodge hotels currently unavailable
Incident Report for Click Travel Ltd
Resolved
Our supplier have resolved their issue and Travelodge hotels are available on the platform again. Apologies for any inconvenience caused.
Posted Nov 29, 2022 - 13:52 GMT
Investigating
Due to an issue with a third party supplier, Travelodge hotels are currently unavailable. We are working with our supplier to understand the issue. We apologise for any inconvenience caused.
Posted Nov 29, 2022 - 12:00 GMT
This incident affected: Search (Hotel Search).