Failures with cancelling and exchange e-ticket train bookings

Incident Report for Click Travel Ltd

Resolved

Our supplier has resolved the issue. Apologies for any inconvenience caused.
Posted May 21, 2026 - 09:59 BST

Monitoring

A fix has been implemented and we are monitoring the impact.
Posted May 20, 2026 - 12:04 BST

Identified

Due to a third party supplier issue we are not able to cancel or exchange some e-ticket train bookings. We are awaiting an update from our supplier
Posted May 20, 2026 - 10:34 BST
This incident affected: Booking / Checkout.