Hotel Booking Failures
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 10:29 GMT
Update
The issue preventing booking of hotels with one of our payment providers has been resolved and full functionality has ben restored.
Posted Jan 02, 2022 - 13:15 GMT
Investigating
We are investigating an issue with hotel bookings on our platform, please contact our team if you are experiencing issues
Posted Jan 02, 2022 - 10:54 GMT
This incident affected: Booking / Checkout.