Intermittent issues reserving seats on train bookings

Incident Report for Click Travel Ltd

Resolved

Our supplier has resolved the issue. Apologies for any inconvenience caused.
Posted Apr 15, 2026 - 12:55 BST

Update

We are continuing to investigate this issue.
Posted Apr 15, 2026 - 12:55 BST

Investigating

Due to a third party supplier issue, there are intermittent issues making train bookings, mainly on Northern Trains. If you experience a problem, please try again and if the problem persists, contact Customer Support.
Posted Apr 15, 2026 - 07:40 BST
This incident affected: Booking / Checkout.