Telephony Issues
Incident Report for Click Travel Ltd
Resolved
Our telephony issues are now resolved, but please note we are working at reduced capacity. We appreciate your patience during this time.
Posted 5 months ago. Apr 12, 2019 - 12:37 BST
Investigating
Our telephony provider are currently having issues with their system, they're investigating and hope to resolve soon. If your query is urgent please contact us via email or live chat on the platform. We apologise for any inconvenience caused.
Posted 5 months ago. Apr 12, 2019 - 09:52 BST
This incident affected: Communications (Telephone).