Issue with some Premier Inn bookings and amendments
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 17:09 BST
Update
We are continuing to monitor for any further issues.
Posted Oct 21, 2020 - 14:40 BST
Monitoring
Premier Inn have advised that their reservations system should be working again now. We will be monitoring Premier Inn bookings to ensure that there are no further issues.
Posted Oct 21, 2020 - 14:27 BST
Identified
Our provider, Premier Inn, have advised us of as issue with their systems which is affecting our ability to book, amend or cancel Premier Inn. They are investigating the issue as a priority.

If you need to book Premier Inn, some properties may still be available via our other suppliers, otherwise we would recommend waiting until this incident has been resolved. For urgent bookings, contact our Customer Support team for assistance.

We will resolve this incident once we have received confirmation the issue has been resolved from our provider.
Posted Oct 21, 2020 - 12:32 BST
This incident affected: Search (Hotel Search) and Booking / Checkout.