Travelodge hotels not available on the platform

Incident Report for Click Travel Ltd

Resolved

We have received notification from Travelodge that it has all been resolved. The number of unavailable hotel searches with them have reduced significantly and searches for Travelodge hotels have become stable.
Posted Jun 12, 2025 - 15:42 BST

Investigating

Due to an issue with our third party supplier, Travelodge hotels are unavailable on the platform. We are working with our supplier to understand the issue. We apologise for any inconvenience caused.
Posted Jun 12, 2025 - 14:54 BST
This incident affected: Search (Hotel Search).