Intermittent issues making EasyJet bookings
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved by our supplier and all EasyJet bookings are now going through successfully. Apologies for any inconvenience caused.
Posted Jan 18, 2022 - 14:44 GMT
Investigating
One of our suppliers is experiencing issues which is causing EasyJet bookings to intermittently fail. We are working with them to understand the reason for the failures.
Posted Jan 18, 2022 - 10:11 GMT
This incident affected: Booking / Checkout.