Booking.com channel outage

Incident Report for Click Travel Ltd

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 12:21 GMT

Monitoring

Awaiting for Booking.com to stabilise
Posted Mar 05, 2026 - 11:45 GMT

Investigating

We are currently experiencing a total outage with Booking.com, will update as soon as we hear back from them about the issue they are experiencing.
Posted Mar 05, 2026 - 11:28 GMT
This incident affected: Booking / Checkout.