Car Hire & Hotel Search Not Working

Incident Report for Click Travel Ltd

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 15:36 BST

Monitoring

A fix has been implemented and we are monitoring results.
Posted Jul 01, 2026 - 13:00 BST

Investigating

We are currently investigating an issue with Care Hire and Hotel search.
Posted Jul 01, 2026 - 12:27 BST
This incident affected: Search (Hotel Search, Car Hire Search).