Premier Inn bookings failing
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved. Apologies for any inconvenience caused.
Posted Nov 06, 2024 - 13:03 GMT
Monitoring
Our supplier has implemented a fix and Premier Inn booking are going through successfully again. We will continue to monitor.
Posted Nov 06, 2024 - 12:49 GMT
Investigating
Due to an error with a third party supplier Premier Inn bookings are failing on the platform. We are working with the supplier to understand the issue. We apologise for any inconvenience.
Posted Nov 06, 2024 - 12:26 GMT
This incident affected: Booking / Checkout.