Corona Virus Rail update
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Mar 15, 2020 - 13:12 GMT
Update
We are continuing to investigate this issue.
Posted Mar 13, 2020 - 14:49 GMT
Investigating
We are experiencing high volumes of questions with regards to train tickets. We are working closely with all Rail Operators. They continue to operate as normal and as such, the terms and conditions of tickets are as purchased. We will continue to monitor this situation and provide updates as and when they are received
Posted Mar 13, 2020 - 14:47 GMT
This incident affected: Search (Train Search).