Travelodge hotel searches returning no results.
Incident Report for Click Travel Ltd
Resolved
Our supplier have resolved their issue and Travelodge hotels are available on the platform again. Apologies for any inconvenience caused.
Posted Oct 06, 2023 - 15:38 BST
Investigating
We are currently investigating the issue and have reached out to our supplier.
Posted Oct 06, 2023 - 12:40 BST