Delay with offline service
Incident Report for Click Travel Ltd
Resolved
We are now back to normal service
Posted 7 days ago. Jun 12, 2019 - 02:56 BST
Identified
We are experiencing a delay in replying to our email channels due to a networking issue. If your query is of an urgent nature please call us or use our online chat service. Sorry for any inconvenience caused
Posted 7 days ago. Jun 11, 2019 - 14:01 BST
This incident affected: Communications (Email (Outbound & Inbound)).