Issues sending faxes
Incident Report for Click Travel Ltd
Resolved
This issue is now resolved. Faxes are being sent successfully.
Posted 3 months ago. Mar 28, 2019 - 14:42 GMT
Monitoring
Our third party supplier has implemented a fix and faxes are sending successfully. We will continue to monitor the situation.
Posted 3 months ago. Mar 28, 2019 - 12:52 GMT
Investigating
An issue with our third party supplier is resulting in faxes currently not being sent. We are working with our supplier to identify the issue.
Posted 3 months ago. Mar 28, 2019 - 12:36 GMT
This incident affected: Communications (Faxes).