Service Disruption with Flight Search
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted 29 days ago. May 20, 2019 - 21:03 BST
Update
We are continuing to monitor for any further issues.
Posted 29 days ago. May 20, 2019 - 17:55 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 29 days ago. May 20, 2019 - 17:55 BST
Update
Our engineering team are still investigating the route cause of this issue, so that a solution can be implemented as soon as possible.

We are sorry for any inconvenience caused by this service disruption. For any urgent flight bookings, please contact the Customer Support team.
Posted 29 days ago. May 20, 2019 - 14:45 BST
Investigating
We are currently experiencing a service disruption with Flight Search

Our engineering team is working to identify the root cause and implement a solution.

We will update you as soon as possible.
Posted 29 days ago. May 20, 2019 - 13:56 BST
This incident affected: Search (Flight Search).