Outage to product search / book services
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 29, 2019 - 12:42 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Mar 29, 2019 - 12:01 GMT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Mar 29, 2019 - 12:00 GMT
This incident affected: Booking / Checkout.