Unable to display train ticket collection stations
Incident Report for Click Travel Ltd
Resolved
This incident has been resolve. Apologies for any inconvenience caused.
Posted Aug 09, 2022 - 16:49 BST
Investigating
We are currently unable to display information on the stations where train tickets can be collected due to an issue with a third party supplier. In the meantime, please consult the National Rail website for information in which stations allow tickets to be collection. We are working with our supplier to understand the issue and apologise for any inconvenience caused.
Posted Aug 08, 2022 - 12:33 BST
This incident affected: Booking / Checkout.