Ryanair Instability
Incident Report for Click Travel Ltd
Resolved
Ryanair has been re-enabled and our third party supplier notes the airline is performing better now.
Posted 5 months ago. Apr 09, 2019 - 12:39 BST
Monitoring
Our third party supplier is reporting that Ryanair are suffering instability and search results for Ryanair are now no longer being displayed.

We are monitoring the situation.
Posted 5 months ago. Apr 09, 2019 - 11:21 BST
This incident affected: Search (Flight Search).