Train bookings are failing
Incident Report for Click Travel Ltd
Resolved
We are confident that the issue with failed train bookings has now been resolved. Thank you for your patience.
Posted 23 days ago. May 27, 2019 - 10:39 BST
Monitoring
We have identified the issue, and are keeping an eye on train bookings to ensure that things are now working as expected. Thank you for your patience.
Posted 23 days ago. May 27, 2019 - 10:05 BST
Investigating
We are currently investigating an issue where train bookings are failing. We will update as soon as we have further information.
Posted 23 days ago. May 27, 2019 - 08:33 BST
This incident affected: Booking / Checkout.