Intermittent failures to search, cancel and book Premier Inns
Incident Report for Click Travel Ltd
Resolved
This incident has been resolved.
Posted Jul 11, 2019 - 18:22 BST
Monitoring
The issues with searching and booking Premier Inn hotels have been resolved, please retry your searches and bookings and thank you for your patience.
Posted Jul 11, 2019 - 18:20 BST
Investigating
We are currently experiencing an intermittent issue connecting to Premier Inn which is affecting our ability to search, cancel and book rooms with them.

We will are currently investigating.
Posted Jul 11, 2019 - 17:12 BST
This incident affected: Search (Hotel Search) and Booking / Checkout.