Issues with Live Chat
Incident Report for Click Travel Ltd
Resolved
The issue with Live Chat is now resolved and we're dealing with requests/queries. Thank you for your patience during this time.
Posted 3 months ago. Mar 21, 2019 - 14:46 GMT
Update
Our live chat service is now back up and running, our agents are working through the backlog and will get back to you ASAP. If query is urgent, please contact the travel team via the usual email and phone methods. We apologise for any inconvenience caused.
Posted 3 months ago. Mar 21, 2019 - 12:37 GMT
Identified
We're currently experiencing issues with our Live Chat service, our supplier is aware of the problem and are working to resolve it. If query is urgent, please contact the travel team via the usual email and phone methods. We apologise for any inconvenience caused.
Posted 3 months ago. Mar 21, 2019 - 11:37 GMT
This incident affected: Intercom Web Messenger, Intercom Mobile Messenger, and Intercom Intercom Web Application.