Mobile app sign-in is not working.

Incident Report for Click Travel Ltd

Resolved

This incident has been resolved. Apologies for any inconvenience caused.
Posted May 12, 2026 - 17:30 BST

Investigating

We are currently investigating an issue with mobile app sign-in not working.
Posted May 12, 2026 - 09:50 BST