Intermittent failures making airport parking bookings

Incident Report for Click Travel Ltd

Resolved

Our third party supplier has resolved the issue as we are seeing no problems when making airport parking bookings. We apologise for any inconvenience caused.
Posted May 08, 2026 - 17:17 BST

Investigating

Due to instability with a third party provider we are currently seeing intermittent failures making airport parking bookings. If you are affected please try again and if the problem persists, contact support. Apologies for any inconvenience caused.
Posted May 08, 2026 - 15:32 BST
This incident affected: Booking / Checkout.